ACCUEIL  »  FORUM  »  LA VIE DU SITE  » POSTER UNE IMAGE SUR LE SITE
 
RETOUR VERS LA LISTE DES MESSAGES
 Suiv. Fin
POSTER UNE IMAGE SUR LE SITE

Laurent P | Administrateur | 52 ans | 5,784 Messages | 1,495 images | Blog Hors ligne
Sujet
Posté le 14-05-2015, à 12:47

Salut,

La nouvelle version du site utilise un script d'envoi d'image quelque peu remanié. Basé sur du HTML5, il n'est compatible qu'avec des navigateurs récents, si vous utilisez une version d'Internet Explorer inférieure à la version 10 vous verrez apparaître un message d'avertissement à la place de l'habituel bouton Parcourir.
Pas de soucis en revanche à partir des navigateur Chrome ou Firefox, je vous invite par ailleurs fortement à utiliser ce dernier au quotidien.

Détaillons un peu la procédure. Au lancement de la page de rédaction du post, vous devez avoir l'affichage suivant :




Cliquez sur Parcourir et choisissez une image. Une miniature de cette image s'affiche alors sur le côté droit et un bouton rouge Envoyer apparaît alors.




A ce stade, l'image n'est pas encore sur le site. Cliquez Sur Envoyer afin de lancer le transfert de l'image vers le site.
Pendant le transfert, une barre de progression vous indique l'avancement de l'opération, c'est généralement assez rapide.




En fin de transfert, un message vous indique que le fichier a été envoyé sans erreur.
Il vous reste à cliquer (dans votre post) à l'endroit où vous souhaitez insérer cette image, puis à cliquer sur le bouton rouge insérer.
Une chaine de caractères composée de 2 balises et du chemin vers l'image doit alors apparaître dans votre message.





Bon, ça ne marche pas ?

Le script utilise javascript, cette fonction doit donc être activée au niveau de votre navigateur. Notez que c'était déjà le cas avec l'ancienne version du site, si ça fonctionnait c'est que le souci est ailleurs.

Les navigateurs utilisent un système de mise en cache des fichiers des sites web visités. En clair, avant de télécharger un fichier en provenance d'un site web, la navigateur vérifie dans son cache local s'il n'est pas déjà stocké. Si c'est le cas, il utilise ce fichier local dans un souci de gain de temps.
Vu que les fichiers de la nouvelle version du site portent les mêmes noms que ceux de l'ancienne, il est donc possible que ce système de cache perturbe le fonctionnement de mon script. La solution est de purger les fichiers internet temporaires à partir du menu de paramétrage de votre navigateur.
Ne pouvant pas décrire cette manip pour chaque version, je vous laisse chercher sur le Web la procédure adaptée à la vôtre, c'est pas bien compliqué.
Notez que la combinaison de touches Control + F5 permet de forcer la chargement des fichiers appelés par la page internet en cours, vous pouvez toujours tenter cela avant de purger la cache dans son intégralité.

J'ai de mon côté testé le script avec tous les navigateurs que j'avais sous la main. Si vous n'arrivez pas à le faire fonctionner, indiquez-moi le navigateur que vous utilisez ainsi que sa version afin que je puisse regarder ça de plus près.

Notez enfin que toutes les rubriques du site proposant un envoi d'image (annonces, fiches motos, motos volées,...) sont désormais basées sur ce nouveau système.





Moto(s): 125 YZMX 1979, 175 IT 1978 "DG", 250 IT 1978, 50 YZMX 1978


Laurent P | Administrateur | 52 ans | 5,784 Messages | 1,495 images | Blog Hors ligne
rep 1/31
Posté le 14-05-2015, à 13:12

Essai à partir d'un Windows phone




Moto(s): 125 YZMX 1979, 175 IT 1978 "DG", 250 IT 1978, 50 YZMX 1978


Laurent P | Administrateur | 52 ans | 5,784 Messages | 1,495 images | Blog Hors ligne
rep 2/31
Posté le 14-05-2015, à 13:19

Essai à partir d'un IPhone 4s




Moto(s): 125 YZMX 1979, 175 IT 1978 "DG", 250 IT 1978, 50 YZMX 1978


Laurent P | Administrateur | 52 ans | 5,784 Messages | 1,495 images | Blog Hors ligne
rep 3/31
Posté le 14-05-2015, à 13:25

Essai Android 4.4




Moto(s): 125 YZMX 1979, 175 IT 1978 "DG", 250 IT 1978, 50 YZMX 1978


Laurent P | Administrateur | 52 ans | 5,784 Messages | 1,495 images | Blog Hors ligne
rep 4/31
Posté le 14-05-2015, à 13:28

Essai Windows 7 IE 11




Moto(s): 125 YZMX 1979, 175 IT 1978 "DG", 250 IT 1978, 50 YZMX 1978


Roberto75015 | 58 ans | 507 Messages | 593 images | Blog Hors ligne
rep 5/31
Posté le 14-05-2015, à 13:36

Avec Chrome 42.0.2311.135 j'y arrive pas, il y a pas de buton "envoyer" apres avoir choisi le fichier



Moto(s) : husqvarna wr 125 1985


Laurent P | Administrateur | 52 ans | 5,784 Messages | 1,495 images | Blog Hors ligne
rep 6/31
Posté le 14-05-2015, à 13:45

Salut Roberto,
Test sous Chrome, on a quasiment la même version, c'est quoi ton système d'exploitation ?




Ça tourne. As-tu purgé les fichiers temporaires ?
Fais CTRL + MAJ + SUPPR pour afficher la fenêtre suivante, configure-la comme ceci et clique sur Effacer les données de navigation




Moto(s): 125 YZMX 1979, 175 IT 1978 "DG", 250 IT 1978, 50 YZMX 1978


Laurent P | Administrateur | 52 ans | 5,784 Messages | 1,495 images | Blog Hors ligne
rep 7/31
Posté le 14-05-2015, à 13:53

Essai à partir d'une image de 6 Mo

Ça fonctionne mais la vignette d'aperçu ne s'affiche pas, à la place on a un message avertissant que le temps de transfert risque d'être long à cause de la taille de l'image.




Moto(s): 125 YZMX 1979, 175 IT 1978 "DG", 250 IT 1978, 50 YZMX 1978


Alain 37 | 58 ans | 2,754 Messages | 2,101 images | Blog Hors ligne
rep 8/31
Posté le 14-05-2015, à 13:58
roberto75015 a écrit :

Avec Chrome 42.0.2311.135 j'y arrive pas, il y a pas de buton "envoyer" apres avoir choisi le fichier

Je viens de mettre la version 42-0-2311-152_fr portable (qui s'exécute dans un dossier sans installation dans le répertoire "program files" donc utilisable sur une clé USB comme ça on peut avoir le GV partout avec soi)  et ça fonctionne bien comme avec Firefox.
Et maintenant il y a même un correcteur d'orthographe, on n'aura plus d'excuses  rire 
Pour Laurent tu veux la mettre à disposition des membre du GV dis moi comment te l'envoyer (le programme d’installation ne fait que 1,34 Mo)
Trop ballot d'être privé de GV.



La règle d'or de la conduite est la tolérance mutuelle, car nous ne penserons jamais tous de la même façon, nous ne voyons qu'une partie de la vérité et sous des angles différents.Moto(s) : HM 230, Honda 200 XLR, Honda 125 SL, HVA 240 WR 82, Suzuki VanVan 50 et quelques vieux cyclos


Jotrajectoire | 69 ans | 2,139 Messages | 4,328 images | Blog Hors ligne
rep 9/31
Posté le 14-05-2015, à 14:03

bonjour Laurent

je suis Out ,pour les  Images , pas de voyant rouge en vue ,  au plaisir , jo



Moto(s) : cz- aprilia- YAM cheney- FABER BSA-


Roberto75015 | 58 ans | 507 Messages | 593 images | Blog Hors ligne
rep 10/31
Posté le 14-05-2015, à 14:06

je suis sur win 8.1, je vais mettre a jour redemarrer la machine et essayer encore :-D



Moto(s) : husqvarna wr 125 1985


Laurent P | Administrateur | 52 ans | 5,784 Messages | 1,495 images | Blog Hors ligne
rep 11/31
Posté le 14-05-2015, à 14:06

Salut Jo,
Connais-tu la version de ton navigateur ?



Moto(s): 125 YZMX 1979, 175 IT 1978 "DG", 250 IT 1978, 50 YZMX 1978


Roberto75015 | 58 ans | 507 Messages | 593 images | Blog Hors ligne
rep 12/31
Posté le 14-05-2015, à 14:11

je viens de mettre a jour avec version Version 42.0.2311.152 et ca marche   smiley_07  smiley_07 









Moto(s) : husqvarna wr 125 1985


Jotrajectoire | 69 ans | 2,139 Messages | 4,328 images | Blog Hors ligne
rep 13/31
Posté le 14-05-2015, à 14:26

2006 WINDOWS . MAIL - MICROSOFT=corporation , je suis nul , sur le problème , c'est bon pour la poubelle , oui ou non .............



Moto(s) : cz- aprilia- YAM cheney- FABER BSA-


BERNARD | 58 ans | 11,817 Messages | 2,161 images | Blog Hors ligne
rep 14/31
Posté le 14-05-2015, à 16:07

j ai nettoyé mes caches et vidé les Téléchargements et ça marche   smiley_07 





Uniquement  Pour  Le  Plaisir  ..........
www.tayamaha.com

Le site de la pièce yamaha anciennes et moins anciennes
Moto(s) : xt 600 xr 125

 
RETOUR VERS LA LISTE DES MESSAGES
 Suiv. Fin
Voir les 26 images de ce sujet









158 connectés : 9 membres :
husky64 | JLB56 | JPH74 | Le baron de l'écluse | lucd | mxonly | nico-moto-36 | O.Morhaut | xt 500 | et 149 invités